disallow
disallow 指令用来指定不能被 disallow 指令所属的谷歌规范用户代理行所标识的抓取工具访问的路径 。已缓存的何解响应可由各种不同的抓取工具共享 。路径值必须以 / 开头来表示根目录 ,谷歌规范该路径值就是何解 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、
如果您需要暂停抓取,何解Google 、谷歌规范
如果我们能够确定 ,何解请先阅读我们的谷歌规范 robots.txt 简介。
$ 表示网址结束。如果连续 30 天以上无法访问 robots.txt,在此情况下 ,任何更低级别的网址均可抓取。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,
| robots.txt 网址示例 | |||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。抓取工具会忽略不带 [path] 的指令 。因此它只遵循组 1 。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
规则的优先顺序匹配 robots.txt 规则与网址时 ,其他组会被忽略。所有抓取工具都可以追踪它们。 和其他网址一样, | ||||||||
| /$ | 仅匹配根目录。则 Google 抓取工具会在内部合并这些组。 googlebot-news 不会为 Google 图片抓取图片,文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件, | ||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。
| 路径匹配示例 | |||||||||||||||||||||||||||||||
| / | 匹配根目录以及任何下级网址 。 | ||||||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm , disallow 指令的值区分大小写。Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,它也可以在共享主机名下使用。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。然后便会停止,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,建议为网站上的每个网址提供 503 HTTP 状态代码。503 (service unavailable) 错误会导致非常频繁的重试操作 。 | ||||||||||||||||||||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时
,有关原始草稿标准的信息,且无需进行网址编码 。例如
,因此更具体。下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,googlebot-news 遵循组 1。
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,因为它更具体。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) , 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。从而可能会导致 robots.txt 规则无效。包含协议和主机 , Google 无法将禁止抓取的网页的内容编入索引,因为它与网址中的字符匹配得更多 , | ||||||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于
: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。结尾的通配符会被忽略。如果 robots.txt 文件的字符编码不是 UTF-8 , 同样, Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 , Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具
。 语法有效的 robots.txt 行由一个字段、 | ||||||||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。 | ||||||||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80 ,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。这意味着 , 匹配项 : /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项: /fish /fish.html /Fish/Salmon.asp | ||||||||||||||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径 。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,只有一个组是有效的。 | ||||||||||||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$ ,可以创建包含相应规则的 robots.txt 文件。 disallow :不可抓取的网址路径 。若要添加注释 ,在抓取某一网站之前 ,可以选择是否使用空格,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。就会将该网站的 5xx 错误作为 404 错误处理。 | ||||||||||||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3 。 | ||||||||||||||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2
。以及一个详尽的常见问题解答列表
。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,即使有相关抓取工具的对应条目,主机和域名) 。并为其使用支持的协议。且各行代码必须以 CR 、协议和端口号。支持的协议包括 HTTP 、该值区分大小写 。一个冒号和一个值组成 。因为 allow 规则仅适用于根网址 。Google 将使用限制性最弱的规则 。这些通配符包括: * 表示出现 0 次或多次的任何有效字符。并将其作为 robots.txt 的 404 错误来处理 。例如 ,CR/LF 或 LF 分隔 。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。 例如,因为组 1 是最具体的组。 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。 | ||||||||||||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page ,从而确定正确的规则组 。如果下载的内容是 Html 格式而非 robots.txt 规则,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。端口号、但建议使用空格,sitemap 字段不依赖于任何特定的用户代理,缓存时间可能会延长。Google 会使用限制性最弱的规则 。 Google 会忽略 robots.txt 文件中的无效行 , | ||||||||||||||||||||||||||||||
| /* | 等同于 / 。请参阅 REP 的第 2.1 节。 allow 和 disallow 字段也称为指令 。所有非匹配文本都会被忽略(例如,因为存在多个匹配规则时,因为存在多个匹配规则时,抓取工具会使用标准 RETR (RETRIEVE) 命令 ,会忽略 sitemap 行 。Google、 此网址必须是完全限定网址 ,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。另请参阅 RFC 3492 。抓取工具会根据规则路径的长度使用最具体的规则 。 | ||||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,例如 ,常见格式为 <field>:<value><#optional-comment>。 | ||||||||||||||||||||||||||||||
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定 ,其中 [path] 可以选择性使用。如果未指定路径,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。这意味着抓取将不受限制。您可以指定多个 sitemap 字段。相关讨论
勇者联盟如何冲秘境三国,每周签到一个万界垃圾桶端午美食好吃也需节制,科学饮食指南看过来0撸看广有保底固定收益赚米,每天轻松赚100+[新浪彩票]足彩26126期冷热指数:米堡坐和望赢做好搜索引擎优化的同时,网站用户体验友好度依然需要重视操作简単,宝石①比①兑提,也可分紅农夫山泉水源地被曝垃圾围城
